Forum

Chameleon 1.0.9 cra...
 
Notifications

[Solved] Chameleon 1.0.9 crash's and don't save my old or new Templates!!?  

  RSS

Runnin@live
(@runninlive)
Active Member Registered
Joined: 1 year ago
Posts: 6
04/01/2020 2:58 pm  

Hello Pablo

My Issue is as stated, I can't save my Templates neither my old nor new ones, chameleon just crashes!?

I tried different things like:

Restarted the computer after chameleon 1.0.9 update installation

Starting as administrator, system and user wide

Using another save location like desktop and other hard drives

I didn't install any midi driver or other driver for at least 10 months

I just have one suspicion, I disabled system broker manager, I had some performance issues.

Maybe chameleon needs this service, in order to write to the hard drive...., I don't know??

 

Is there crash file from Chameleon somewhere that I can find and provide to you...?

 

This topic was modified 2 months ago by [email protected]

Quote
Topic Tags
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 449
04/01/2020 9:03 pm  

Hi, no exist any crash log.
Chameleon just usually not crash.

Have a chance to test in  a second computer ?
Can send one of your older templates to me?
That older templates are created on what version of software?
Can create a template with just one button inside and then select save......that action crash the software?

Already try enabling system broker  again and all what you disable?

This post was modified 2 months ago 2 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
Runnin@live
(@runninlive)
Active Member Registered
Joined: 1 year ago
Posts: 6
05/01/2020 9:34 am  

Sorry for the late replay, I live in Middle Europe, so time for you and me is different.

No chance for me to try it on another PC!

The older template is made with 1.06 or 1.07(I Give You The Download link*)!

I created a template with just one button, but nothing changed, it just crashes to desktop!

And I enabled system broker manager, but no change!

 

Link*:

REMOVED.

 

This post was modified 1 month ago by SaveTheHuman5

ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 449
05/01/2020 12:03 pm  

Load here without trouble.
After load can save also.
I don't know what services you disabled, can provide a full list?

template

I think the only way to debug will be you run anydesk software and provide to me with access to take a look in your computer.

This post was modified 2 months ago 4 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
Runnin@live
(@runninlive)
Active Member Registered
Joined: 1 year ago
Posts: 6
05/01/2020 12:23 pm  

I already gone truth everything with system broker service off an on, but nothing changed!?

And there is just one thing I changed the last 10+ month, and that is system broker manager(About 3 Months Ago) and chameleon updates.

The service is up and running right now.

I don't update my audio and other apps very often, just 1 or 2 times a year.

If everything works, then I don't update!


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 449
05/01/2020 12:29 pm  

The only way to debug this will be with access to your computer using anydesk software, is safe and secure , download an run from https://anydesk.com
If you want move forward please let me know: https://hi.computer/contact/

This post was modified 2 months ago 2 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 449
15/01/2020 11:36 am  

Problem fixed using remote access, not is a direct bug on the software is a  un-handled exception.  [email protected] try to write/save template outside the default folder for templates what is granted by windows to allow write files. More info how use save and about folder structure, updated link:  https://hi.computer/chameleon-user-guide/#saving-a-template    Knowing what happen  here, now I  plan add exception handling and some rules to prevent this happen to other user in the future.

[email protected] also use UAC disable, what probably (or not) can be also responsive of the problem. Sorry I not take a deep look on that, UAC need be enabled.
Chameleon need run with elevated privileges and UAC need be enabled,  any action of disable security of windows can cause problems.
Is really extreme bad idea disable UAC.

This post was modified 1 month ago 8 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 449
15/01/2020 11:47 am  

Changelog update, the code is improved preventing this happen again to  other users:

https://hi.computer/forum-community/announcements-releases/chameleon-releases/

This post was modified 1 month ago 4 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote