Forum

Certain keyboard sh...
 

Certain keyboard shortcuts intercepted  

  RSS

TabbyCat
(@tabbycat)
New Member Registered
Joined: 5 months ago
Posts: 4
06/05/2019 9:21 pm  

First off -- geez is this software amazing! In my studio I have a gaming keyboard with all sorts of extra function keys, and it's great to use them to shift between MIDI targets! 😀 

I've noticed that when Elephant is running, certain system-wide shortcuts are intercepted. For example, I have application shortcuts assigned to Ctl+Shift+E, Ctl-Alt+E, Ctl+Shift+C, etc. Some of the shortcuts launch applications, some of them are hotkeys inside Reaper, etc. While Elephant is running, the shortcuts don't reach their target. If I close Elephant, they start working again.

To be clear - none of the mentioned shortcuts are assigned in Elephant, they are only assigned in other applications.

Any ideas?

Cheers!


Quote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
07/05/2019 6:27 am  

I take a look soon.
No idea why happen.

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
18/05/2019 10:37 am  

I make some test and are unable to reproduce the issue you report.
I test as example with CONTROL + ALT + T    what is a default action come with software and work ok.
I open action menu, and search for shortcut , I search for CONTROL + ALT + E
Here, Reaper and other apps pickup all hotkeys when Chameleon is open.
Without  reproduce the issue, there is no way to fix something I can't see.
Had a chance to setup and test in other machine, and check if also happen?

This post was modified 4 months ago 2 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
08/06/2019 7:11 am  

Hello some update from your side?

This post was modified 3 months ago by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
TabbyCat
(@tabbycat)
New Member Registered
Joined: 5 months ago
Posts: 4
11/06/2019 5:19 pm  

Hi - sorry for delay!

After spending more time with it, I do have the issue intermittently with various apps - but the one app I am able to reproduce every time is Native Access (Native Instruments). When Elephant is running, along with Native Access, I am unable to click the "login" button, or any of the "update" buttons for example. If I close Elephant, everything in Native Access immediately works as normal.

Other than that, it's working great - this isn't a "show stopper", so I am content closing Elephant when I need to run NI updates  😉


ReplyQuote
TabbyCat
(@tabbycat)
New Member Registered
Joined: 5 months ago
Posts: 4
11/06/2019 5:28 pm  

And - I just discovered Panda! I didn't know you made this app, I just finished programming a complicated AutoHotKey script to move my mouse pointer back...I could have saved a Saturday afternoon  😆 


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
11/06/2019 10:44 pm  

Next version of Chameleon include that feature (same what panda do)
I have native instrument  running here, not able to reproduce the issue. Probably is related to your keyboard or some local hardware.

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
TabbyCat
(@tabbycat)
New Member Registered
Joined: 5 months ago
Posts: 4
12/06/2019 5:11 pm  

OK, thanks for the reply - that's helpful to know. I'll try disabling various devices/services until I find the troublemaker.

 

Cheers!


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
13/06/2019 12:15 am  

Great, let me know the results of your tests.

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote

Please Login or Register