Forum

Elephant Not Workin...
 

Elephant Not Working In Windows Standard User Account  

  RSS

mtrigoboff
(@mtrigoboff)
Active Member Customer
Joined: 2 weeks ago
Posts: 6
01/09/2019 7:42 pm  

I just downloaded, installed, and activated Elephant.

For security reasons, the Windows account I usually use for doing music is a Standard User account. Elephant does not work when I am logged into that account.

I tried using Elephant logged into an Administrator account, and it worked just fine that way.

Is there a way to get Elephant to work properly in a Standard User account?

Surface Pro tablet. Windows 10 Pro updated to latest version. Cubase 10 pro, version 10.0.30. 

 

This topic was modified 2 weeks ago by mtrigoboff

Quote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
01/09/2019 7:53 pm  

Hello!

Elephant need admin rights. The software request admin rights when start and ask to user for elevation of privileges. Is UAC disabled in your setup?  

What message error you see when run the software?

This post was modified 2 weeks ago 3 times by SaveTheHuman5

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
mtrigoboff
(@mtrigoboff)
Active Member Customer
Joined: 2 weeks ago
Posts: 6
01/09/2019 8:39 pm  

Thanks for the incredibly quick response! 

There are no error messages.

When I start Elephant, UAC comes up and I give my administrator password. Elephant seems to start up just fine. I see the splash screen.

But once it’s running, Elephant doesn’t work. Double clicking the Surface Dial does not bring up the Elephant user interface.

Double clicking the Escape key does bring it up. But when I bring up Elephant that way, turning the Dial does not do anything.  Also, Elephant does not control any of the sliders or knobs in Cubase.

I tried Elephant on the same machine in an Administrator account, and it seems to work just fine that way.

I have a temporary fix. I converted my Standard User account to an Administrator account. Elephant is working fine in that account now. But I would be happy to do most of my work in a Standard User account  to make my machine more secure. 

 

This post was modified 2 weeks ago by mtrigoboff

ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
01/09/2019 8:46 pm  

OK. I take a look on this issue. First need reproduce the issue. 

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
01/09/2019 8:48 pm  

Can try please uninstall Elephant with that users as admin.  Reinstall again. And then turn that user in a standar user and try if issue is solved?

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
mtrigoboff
(@mtrigoboff)
Active Member Customer
Joined: 2 weeks ago
Posts: 6
01/09/2019 9:49 pm  

I just did exactly what you asked. Elephant still does not work in a Standard User account.

Then I changed the account back to an Administrator account, and now Elephant works fine again in that account.


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
01/09/2019 10:10 pm  

I check this and back to you in few days. Chameleon do a deep access to some windows API, so probably there is no way to fix this. In that case the only way to use will be with the default windows setup, what is a user running as admin. More info soon.

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote
mtrigoboff
(@mtrigoboff)
Active Member Customer
Joined: 2 weeks ago
Posts: 6
02/09/2019 12:05 am  

This is the best tech support I have ever experienced. Thanks!


ReplyQuote
SaveTheHuman5
(@savethehuman5)
Member
Joined: 2 years ago
Posts: 329
02/09/2019 11:21 pm  

Thanks for your words.
After some coding and research across all day,  I can confirm the only way to use the software is under admin user.
I try next week again, if this is a problem for you and is mandatory run standard user, you can request a refund.

Facebook, Twitter, Instagram: @SaveTheHuman5


ReplyQuote

Please Login or Register